
<!doctype html>
<html class="no-js" lang="en-US" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb#" >
    <head>

        <meta charset="UTF-8" />
        <meta name="viewport" content="width=device-width, initial-scale=1.0" />
        <meta http-equiv="cache-control" content="no-cache" />
        <link rel="icon" href="http://3gipq24d7ux62drxrjfr3ih1.wpengine.netdna-cdn.com/wp-content/themes/BlackPress/assets/images/icons/favicon.ico" type="image/x-icon">
        <link rel="apple-touch-icon" sizes="144x144" href="http://3gipq24d7ux62drxrjfr3ih1.wpengine.netdna-cdn.com/wp-content/themes/BlackPress/assets/images/icons/apple-touch-icon-144x144.png">
        <link rel="apple-touch-icon" sizes="114x114" href="http://3gipq24d7ux62drxrjfr3ih1.wpengine.netdna-cdn.com/wp-content/themes/BlackPress/assets/images/icons/apple-touch-icon-114x114.png">
        <link rel="apple-touch-icon" sizes="72x72" href="http://3gipq24d7ux62drxrjfr3ih1.wpengine.netdna-cdn.com/wp-content/themes/BlackPress/assets/images/icons/apple-touch-icon-72x72.png">
        <link rel="apple-touch-icon" href="http://3gipq24d7ux62drxrjfr3ih1.wpengine.netdna-cdn.com/wp-content/themes/BlackPress/assets/images/icons/apple-touch-icon.png">
        <title>Rita Fromme - Yukon News</title>
<!--
<PageMap>
	<DataObject type="thumbnail">
		<Attribute name="src" value="http://3gipq24d7ux62drxrjfr3ih1.wpengine.netdna-cdn.com/wp-content/uploads/2017/11/A7J0P6W6-20171117101316-200x300.jpg"/>
		<Attribute name="width" value="300"/>
		<Attribute name="height" value="200"/>
	</DataObject>
</PageMap>
-->
<!-- This site is optimized with the Yoast SEO plugin v5.4 - https://yoast.com/wordpress/plugins/seo/ -->
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Rita Fromme - Yukon News" />
<meta property="og:description" content="Nov 13, 1934 &#8211; Nov 17, 2017Rita Fromme was the oldest of nine children raised on a small farm on the Gaspe Peninsula. Her father grew root vegetables cherries and apples. Though the family&#8217;s income was meagre, Rita remembered her parents as loving who provided their family with a good start in life. She attendedRead more..." />
<meta property="og:site_name" content="Yukon News" />
<meta property="article:section" content="Obituaries" />
<meta property="article:published_time" content="2017-11-17T08:00:00-08:00" />
<meta property="fb:app_id" content="122141995084732" />
<meta property="og:image" content="http://www.yukon-news.com/wp-content/uploads/2017/11/A7J0P6W6-20171117101316.jpg" />
<meta property="og:image:width" content="400" />
<meta property="og:image:height" content="600" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="Nov 13, 1934 &#8211; Nov 17, 2017Rita Fromme was the oldest of nine children raised on a small farm on the Gaspe Peninsula. Her father grew root vegetables cherries and apples. Though the family&#8217;s income was meagre, Rita remembered her parents as loving who provided their family with a good start in life. She attendedRead more..." />
<meta name="twitter:title" content="Rita Fromme - Yukon News" />
<meta name="twitter:image" content="http://www.yukon-news.com/wp-content/uploads/2017/11/A7J0P6W6-20171117101316.jpg" />
<script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"WebSite","@id":"#website","url":"http:\/\/www.yukon-news.com\/","name":"Yukon News","potentialAction":{"@type":"SearchAction","target":"http:\/\/www.yukon-news.com\/?s={search_term_string}","query-input":"required name=search_term_string"}}</script>
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//ajax.googleapis.com' />
<link rel='dns-prefetch' href='//content.jwplatform.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='stylesheet' id='main-stylesheet-css'  href='http://3gipq24d7ux62drxrjfr3ih1.wpengine.netdna-cdn.com/wp-content/themes/BlackPress/dest/stylesheets/foundation.min.css?ver=2.0.3' type='text/css' media='all' />
<link rel='stylesheet' id='featherlight-css'  href='http://3gipq24d7ux62drxrjfr3ih1.wpengine.netdna-cdn.com/wp-content/themes/BlackPress/assets/components/featherlight/featherlight.css?ver=1.6.1' type='text/css' media='all' />
<script type='text/javascript' src='http://3gipq24d7ux62drxrjfr3ih1.wpengine.netdna-cdn.com/wp-content/plugins/wp-retina-2x/js/picturefill.min.js?ver=3.0.2'></script>
<script type='text/javascript' src='//ajax.googleapis.com/ajax/libs/jquery/2.1.0/jquery.min.js?ver=2.1.0'></script>
<link rel='https://api.w.org/' href='http://www.yukon-news.com/wp-json/' />
<link rel="alternate" type="application/json+oembed" href="http://www.yukon-news.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.yukon-news.com%2Fobituaries%2Frita-fromme%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://www.yukon-news.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.yukon-news.com%2Fobituaries%2Frita-fromme%2F&#038;format=xml" />
<!-- Start Google Analytics Tags -->

<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-6969668-1', 'auto');
  ga('send', 'pageview');

</script>
				
<!-- End Google Analytics Tags -->

<!-- Start: Yukon Styles -->
<style>

@media screen and (max-width: 39.9375em){
  #header-second-row {
    background-color: #f9b121;
  }
  .bp-pub-logo {
    fill: black;
  }
  #weatherContainer a {
    color: black;
  }
}

</style>
<!-- End: Yukon Styles --><script type="application/ld+json">{"@context":"http:\/\/schema.org","@type":"NewsArticle","url":"http:\/\/www.yukon-news.com\/obituaries\/rita-fromme\/","mainEntityOfPage":{"@type":"WebPage","@id":"http:\/\/www.yukon-news.com\/obituaries\/rita-fromme\/"},"headline":"Rita Fromme","datePublished":"2017-11-17T08:00:00+00:00","dateModified":"2017-11-17T08:00:00+00:00","thumbnailUrl":"http:\/\/www.yukon-news.com\/wp-content\/uploads\/2017\/11\/A7J0P6W6-20171117101316.jpg","image":{"@type":"ImageObject","url":"http:\/\/www.yukon-news.com\/wp-content\/uploads\/2017\/11\/A7J0P6W6-20171117101316.jpg","width":400,"height":600},"author":{"@type":"Person","name":"Wire Service"},"publisher":{"@type":"Organization","name":"Yukon News","logo":{"@type":"ImageObject","url":"http:\/\/www.yukon-news.com\/wp-content\/themes\/BlackPress\/assets\/images\/logos\/ykn-logo.png","width":284,"height":52}},"contentLocation":{"@type":"Place","name":"Whitehorse, Yukon, Canada"},"dateline":"Whitehorse, Yukon, Canada","description":"Nov 13, 1934 &#8211; Nov 17, 2017Rita Fromme was the oldest of nine children raised on a small farm on the Gaspe Peninsula. Her father grew root vegetables cherries and apples. Though the family&#8217;s income was meagre, Rita remembered her parents as loving who provided their family with a good start in life. She attended&lt;a href=http:\/\/www.yukon-news.com\/obituaries\/rita-fromme\/ style=&#039;padding-left:15px;color:#ff6666;&#039;&gt;Read more...&lt;\/a&gt;"}</script><style type='text/css'>
.ai-viewport-3                { display: none !important;}
.ai-viewport-2                { display: none !important;}
.ai-viewport-1                { display: inherit !important;}
.ai-viewport-0                { display: none !important;}
@media (min-width: 768px) and (max-width: 979px) {
.ai-viewport-1                { display: none !important;}
.ai-viewport-2                { display: inherit !important;}
}
@media (max-width: 767px) {
.ai-viewport-1                { display: none !important;}
.ai-viewport-3                { display: inherit !important;}
}
</style>
<!-- DoubleClick for Publishers -->
<script type='text/javascript'>
 var googletag = googletag || {};
 googletag.cmd = googletag.cmd || [];
 (function() {
   var gads = document.createElement('script');
   gads.async = true;
   gads.type = 'text/javascript';
   var useSSL = 'https:' == document.location.protocol;
   gads.src = (useSSL ? 'https:' : 'http:') +
     '//www.googletagservices.com/tag/js/gpt.js';
   var node = document.getElementsByTagName('script')[0];
   node.parentNode.insertBefore(gads, node);
 })();
</script>

<script type='text/javascript'>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</script>
<!-- End DoubleClick for Publishers -->
<!-- 
    * Script creates the global generalSettings js array. 
    * Key/Value pair of Black Press general settings section: option name, option value 
    * NOTE: new options should be added to this array 
-->
<script type='text/javascript'>
        var generalSettings = {"postal_code":"Y1A 2E4","pub_code":"YKN","secondstreet_contest_feed":""};

</script>

<!-- 
    * Script: attaches an event listener to the window's onbeforeunload
    * purpose: fix bug with mobile menu. It prevents the menu bar from 
    * going to the bottom in mobile view.
-->
<script type='text/javascript'>

    function scrollToTop() {

        var mq = window.matchMedia( "screen and (max-width: 39.9375em)" );

        if (mq.matches) {
            window.scrollTo(0,0);
        }
    
    } 

    window.addEventListener("beforeunload", scrollToTop);

</script>

    </head>
    <body class="post-template-default single single-post postid-41798 single-format-standard offcanvas">
        <!-- BEGIN: FACE BOOK COMMENTS PLUGIN CODE -->
        <div id="fb-root"></div>
        <script>(function(d, s, id) {
          var js, fjs = d.getElementsByTagName(s)[0];
          if (d.getElementById(id)) return;
          js = d.createElement(s); js.id = id;
          js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.8";
          fjs.parentNode.insertBefore(js, fjs);
        }(document, 'script', 'facebook-jssdk'));</script>
        <!-- END: FACE BOOK COMMENTS PLUGIN CODE -->

    
    
    
    <header id="masthead" class="site-header row collapse" role="banner">
        <div  class="small-12 columns" data-sticky-container >
            <!-- <div id="sticky-menu-bar-container" class="top-bar sticky row collapse" data-sticky data-options="stickTo:top; " data-margin-top="0" style=""> -->
            <div id="sticky-menu-bar-container" class="top-bar title-bar row collapse" data-sticky data-options="marginTop:0;" style="width:100%">
                <article id="text-1" class="menu-button-container small-1 medium-1 columns">
                    <div id="mobile-menu-button" data-responsive-toggle="site-navigation" data-hide-for="medium">
                        <button class="fa fa-bars menu" type="button" data-toggle="site-navigation"></button>
                    </div>
                    <ul id="menu-mainmenu" class="dropdown menu day-7 show-for-medium" data-dropdown-menu data-options="hoverDelay:150;"><li><a href="#"><i class="fa fa-bars menu"></i></a><ul class="dropdown menu" data-dropdown-menu><li class='nav-search'><a href='http://www.yukon-news.com/search/'><i class='fa fa-search menu'></i>Search</a></li><li id="menu-item-320" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-320"><a href="http://www.yukon-news.com/">Home</a></li>
<li id="menu-item-41562" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-41562"><a href="http://www.yukon-news.com/submit/">Submit News Tip</a></li>
<li id="menu-item-169" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-169"><a href="http://www.yukon-news.com/./news/">News</a>
<ul class="dropdown menu vertical" data-toggle>
	<li id="menu-item-170" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-170"><a href="http://www.yukon-news.com/./local-news/">Local</a></li>
	<li id="menu-item-173" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-173"><a href="http://www.yukon-news.com/e-editions/">eEditions</a></li>
	<li id="menu-item-176" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-176"><a href="http://www.yukon-news.com/submit/">Submit news tip or photo</a></li>
</ul>
</li>
<li id="menu-item-177" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-177"><a href="http://www.yukon-news.com/./sports/">Sports</a>
<ul class="dropdown menu vertical" data-toggle>
	<li id="menu-item-178" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-178"><a href="http://www.yukon-news.com/./local-sports/">Local</a></li>
	<li id="menu-item-180" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-180"><a href="http://www.yukon-news.com/submit/">Submit sports tip or photo</a></li>
</ul>
</li>
<li id="menu-item-181" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-181"><a href="http://www.yukon-news.com/./buzz/">Buzz</a></li>
<li id="menu-item-182" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-182"><a href="http://www.yukon-news.com/./business/">Business</a>
<ul class="dropdown menu vertical" data-toggle>
	<li id="menu-item-183" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-183"><a href="http://www.yukon-news.com/./local-business/">Local</a></li>
	<li id="menu-item-185" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-185"><a href="http://www.yukon-news.com/submit/">Submit business tip or photo</a></li>
</ul>
</li>
<li id="menu-item-186" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-186"><a href="http://www.yukon-news.com/./entertainment/">Entertainment</a>
<ul class="dropdown menu vertical" data-toggle>
	<li id="menu-item-187" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-187"><a href="http://www.yukon-news.com/./local-entertainment/">Local</a></li>
	<li id="menu-item-189" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-189"><a href="http://www.yukon-news.com/submit/">Submit entertainment tip or photo</a></li>
</ul>
</li>
<li id="menu-item-190" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-190"><a href="http://www.yukon-news.com/./life/">Life</a>
<ul class="dropdown menu vertical" data-toggle>
	<li id="menu-item-191" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-191"><a href="http://www.yukon-news.com/./life/">Local</a></li>
	<li id="menu-item-193" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-193"><a target="_blank" href="http://winetrails.ca">Wine Trails</a></li>
	<li id="menu-item-194" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-194"><a href="http://www.yukon-news.com/submit/">Submit life tip or photo</a></li>
</ul>
</li>
<li id="menu-item-195" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-195"><a href="http://www.yukon-news.com/./community/">Community</a>
<ul class="dropdown menu vertical" data-toggle>
	<li id="menu-item-196" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-196"><a href="http://www.yukon-news.com/./community/">Local</a></li>
	<li id="menu-item-197" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-197"><a href="http://www.yukon-news.com/calendar/">Calendar</a></li>
	<li id="menu-item-198" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-198"><a href="http://www.yukon-news.com/submit/">Submit community tip or photo</a></li>
</ul>
</li>
<li id="menu-item-282" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-282"><a href="http://www.yukon-news.com/./opinion/">Opinion</a>
<ul class="dropdown menu vertical" data-toggle>
	<li id="menu-item-204" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-204"><a href="http://www.yukon-news.com/./opinion/">Local Opinion</a></li>
	<li id="menu-item-35827" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-35827"><a href="http://www.yukon-news.com/./wyatts-world/">Wyatt’s world</a></li>
	<li id="menu-item-202" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-202"><a href="http://www.yukon-news.com/./editorials-opinion/">Editorials</a></li>
	<li id="menu-item-201" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-201"><a href="http://www.yukon-news.com/./columns/">Columnists</a></li>
	<li id="menu-item-203" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-203"><a href="http://www.yukon-news.com/./letters-opinions/">Letters</a></li>
	<li id="menu-item-206" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-206"><a href="http://www.yukon-news.com/submitletters/">Submit letter</a></li>
	<li id="menu-item-41442" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-41442"><a href="http://www.yukon-news.com/./web-poll/">Web poll</a></li>
</ul>
</li>
<li id="menu-item-210" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-210"><a href="http://www.yukon-news.com/videos/">Videos</a>
<ul class="dropdown menu vertical" data-toggle>
	<li id="menu-item-211" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-211"><a href="http://www.yukon-news.com/videos/">Local</a></li>
	<li id="menu-item-212" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-212"><a href="http://www.yukon-news.com/submit/">Submit video</a></li>
	<li id="menu-item-213" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-213"><a href="http://blackpress.tv">Black Press TV</a></li>
</ul>
</li>
<li id="menu-item-214" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-214"><a href="http://www.yukon-news.com/weather/">Weather</a></li>
<li id="menu-item-41463" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-41463"><a href="http://www.yukon-news.com/./obituaries/">Obituaries</a></li>
<li id="menu-item-13663" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-13663"><a href="http://www.yukon-news.com/games/">Games</a></li>
<li id="menu-item-217" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-217"><a href="http://www.yukon-news.com/./marketplace/">Marketplace</a>
<ul class="dropdown menu vertical" data-toggle>
	<li id="menu-item-275" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-275"><a href="http://www.yukon-news.com/advertise/">Place an ad</a></li>
	<li id="menu-item-218" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-218"><a href="http://www.yukon-news.com/./marketplace/">Impress branded content</a></li>
	<li id="menu-item-222" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-222"><a href="http://blackpress4good.com">Crowdfunding</a></li>
</ul>
</li>
<li id="menu-item-321" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-321"><a href="http://www.yukon-news.com/contests/">Contests</a></li>
<li id="menu-item-224" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-224"><a href="http://www.yukon-news.com/contact-us/">Contact Us</a>
<ul class="dropdown menu vertical" data-toggle>
	<li id="menu-item-225" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-225"><a href="http://www.yukon-news.com/contact-us/">Contact Us</a></li>
	<li id="menu-item-226" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-226"><a href="http://www.yukon-news.com/our-team/">Our Team</a></li>
	<li id="menu-item-230" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-230"><a href="http://blackpress.ca">Black Press</a></li>
	<li id="menu-item-231" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-231"><a href="http://www.yukon-news.com/submit/">Submit tip or photo</a></li>
	<li id="menu-item-227" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-227"><a href="http://www.yukon-news.com/faq/">FAQ</a></li>
	<li id="menu-item-228" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-228"><a href="http://www.yukon-news.com/privacy-policy/">Privacy Policy</a></li>
	<li id="menu-item-229" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-229"><a href="http://www.yukon-news.com/terms-of-use/">Terms of use</a></li>
</ul>
</li>
<li id="menu-item-27623" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-27623"><a href="#">Archive</a>
<ul class="dropdown menu vertical" data-toggle>
	<li id="menu-item-27628" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-27628"><a href="http://www.yukon-news.com/./multimedia/">Multimedia</a></li>
</ul>
</li>
</ul></li></ul>
                </article>
                <article id="text-2" class="small-10 medium-10 columns">
                    <ul data-test="test" id="menu-secondarymenu" class="dropdown menu" data-dropdown-menu>
									<li id="menu-item-249" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-249"><a href="http://www.yukon-news.com/./news/">NEWS</a>
<ul class="vertical nested menu">
	<li id="menu-item-250" class="show-for-medium menu-item menu-item-type-taxonomy menu-item-object-category menu-item-250"><a href="http://www.yukon-news.com/./local-news/">Local News</a></li>
	<li id="menu-item-252" class="show-for-medium menu-item menu-item-type-post_type menu-item-object-page menu-item-252"><a href="http://www.yukon-news.com/e-editions/">eEditions</a></li>
</ul>
</li>
<li id="menu-item-317" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-317"><a href="http://www.yukon-news.com/./video/">VIDEO</a></li>
<li id="menu-item-13592" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-13592"><a href="http://www.yukon-news.com/classifieds/">CLASSIFIEDS</a></li>
<li id="menu-item-13581" class="show-for-medium menu-item menu-item-type-post_type menu-item-object-page menu-item-13581"><a href="http://www.yukon-news.com/games/">GAMES</a></li>
<li id="menu-item-353" class="show-for-medium menu-item menu-item-type-custom menu-item-object-custom menu-item-353"><a href="/e-editions">E-EDITIONS</a></li>
<li id="menu-item-13580" class="show-for-medium menu-item menu-item-type-post_type menu-item-object-page menu-item-13580"><a href="http://www.yukon-news.com/weather/">WEATHER</a></li>
<li id="menu-item-337" class="show-for-large menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-337"><a href="http://www.yukon-news.com/contact-us/">CONTACT</a>
<ul class="vertical nested menu">
	<li id="menu-item-269" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-269"><a href="http://www.yukon-news.com/contact-us/">Contact Us</a></li>
	<li id="menu-item-41276" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-41276"><a href="http://www.yukon-news.com/our-team/">Our Team</a></li>
	<li id="menu-item-270" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-270"><a href="http://www.yukon-news.com/submit/">Submit news tip or photo</a></li>
</ul>
</li>
<li id="menu-item-336" class="show-for-large menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-336"><a href="http://www.yukon-news.com/./marketplace/">MARKETPLACE</a>
<ul class="vertical nested menu">
	<li id="menu-item-28206" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-28206"><a href="http://www.yukon-news.com/display-advertising/">Display Advertising</a></li>
	<li id="menu-item-262" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-262"><a href="http://www.yukon-news.com/./marketplace/">Impress</a></li>
	<li id="menu-item-266" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-266"><a href="http://blackpress4good.com">Crowdfunding</a></li>
</ul>
</li>
<li id="menu-item-319" class="show-for-large menu-item menu-item-type-post_type menu-item-object-page menu-item-319"><a href="http://www.yukon-news.com/contests/">CONTESTS</a></li>

                                    <li>
                                        <span data-tooltip aria-haspopup="true" data-disable-hover="false" tabindex="1" title="Submit News Tips">
										    <a href="http://www.yukon-news.com/submit">
                                                <img src="http://3gipq24d7ux62drxrjfr3ih1.wpengine.netdna-cdn.com/wp-content/themes/BlackPress/assets/images/submit.png" id="header-submit-button">
                                            </a>
                                        </span>    
									</li>
								</ul>                </article>

                <!-- Search -->
                <article id="text-5" class="small-1 medium-1 columns">
                    <!-- <ul class="dropdown menu float-center" data-dropdown-menu> -->
                        <!-- <li class="nav-search"><a href=""><i class='fa fa-search menu'></i></a></li>
                        -->
                        <button id="btn_search" type="button" class="float-right fa fa-search menu"></button>

                    <!-- </ul> -->
                </article>

                <!-- Search -->
                <article id="div_search" class="small-12 columns">
                <!-- **************** -->
                <!-- Search form container -->
                    <!-- <div id="div_search" style="float-right"> -->
                        <!--<form name="searchForm" action="">
                            <input name="cx" value="015619971846971042401:ufh1ywe-cms" type="hidden">
                            <input name="ie" value="UTF-8" type="hidden">
                        -->
                            <!-- style box-sizing: border-box; - need it here to make  both the search input and submit button smaller, this is the default for bootstrap 3 but it is overwritten
                             in the BC2013 Mobbile Search Results Bootstrap template because it causes issues on the Google Search Engine results form - the buttons were too small and did not 
                             display properly. This template is used by several other templates -->
                         <!--   <input class="searchfield" style="padding: 0px;font-size: 14px;width: 200px;height: 30px;box-sizing: border-box;" name="q" onfocus="clearText(this)" onblur="clearText(this)" value="Story Search" type="text">
                            <input style="padding: 4px;width: 80px;height: 30px;box-sizing: border-box;" value="Search" type="submit">
                        </form>
                        -->


                    <form name="searchForm" action="http://www.yukon-news.com/search/">
  
                        <div class="row collapse">
                            <div class="small-12 columns">

                                <div class="row collapse">
                                    <div class="small-2 medium-3 columns">
                                        &nbsp;
                                      <input name="cx" value="015619971846971042401:ufh1ywe-cms" type="hidden">
                                    </div>

                                    <div class="small-1 medium-3 columns">
                                        &nbsp;
                                      <input name="ie" value="UTF-8" type="hidden">
                                    </div>

                                    <div class="small-6 medium-4 columns">
                                        <input class="google-search-field" name="q" onfocus="clearText(this)" onblur="clearText(this)" value="Story Search" style="" type="text">
                                      
                                       <!-- 
                                      <input class="searchfield" style="" name="q" onfocus="clearText(this)" onblur="clearText(this)" value="Story Search" type="text">
                                    -->
                                    </div>

                                    <div class="small-3 medium-2 columns">
                                      
                                        <input class="google-search-button" value="Search" type="submit">

                                    <!--
                                      <input style="" value="Search" type="submit">
                                         -->
                                    </div>

                                </div>

                            </div>

                        </div>

                          
                    </form>
                        
                    <!-- </div> -->
                <!-- **************** -->
                </article>
                <article class="small-12 medium-12 columns">
                    <div class="line"></div>
                </article>
                
                

            </div>

        </div>
        
        <div class ="row" id="header-second-row">
            <article id="text-12" class="show-for-medium medium-3 columns widget widget_text">			<div class="textwidget"><ul class="social header">
	<!-- <li><a title="Weather" class="social fa fa-cloud" href="/weather/"></a></li> -->
	<li><a title="Follow us on Facebook" class="social fa fa-facebook-f" href="https://www.facebook.com/yukonnews/?fref=ts" target="_blank"></a></li>
	<li><a title="Follow us on Twitter" class="social fa fa-twitter" href="https://twitter.com/yukon_news" target="_blank"></a></li>
	<!--<li><a title="Follow us on Instagram" class="social fa fa-instagram" href="#"  target="_blank"></a></li>-->
</ul></div>
		</article>            <article id="text-11" class="small-8 medium-6 columns widget widget_text">			<div class="textwidget"><a class="pub-logo-large day-7" href="http://www.yukon-news.com/"><svg id="Outline" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 283.24 51.06"><defs><style>.cls-1{fill:#231f20;}</style></defs><title></title><path class="bp-pub-logo" d="M121.69,32.65,113.48,2.5h8.9l4.28,19.25h.14L131.35,2.5h7.52l-8.21,29.33v19.8h-9Z" transform="translate(-113.48 -1.53)"/><path class="bp-pub-logo" d="M141.63,2.5h9v38c0,2.21.48,4.49,3.1,4.49S157,42.86,157,40.52V2.5h7.59V39.34c0,9.66-4.28,13.25-11.45,13.25-6.9,0-11.52-3.59-11.52-13.25Z" transform="translate(-113.48 -1.53)"/><path class="bp-pub-logo" d="M171.44,2.5h9V23.06h.14L188,2.5h8L189.31,19l8.07,32.64h-8.62l-5-22h-.14l-3.24,7.73V51.63h-9Z" transform="translate(-113.48 -1.53)"/><path class="bp-pub-logo" d="M214,1.53c7.94,0,13.11,6.14,13.11,25.53S222,52.59,214,52.59,200.9,46.45,200.9,27.06,206.08,1.53,214,1.53ZM210.7,32.24C210.7,42.86,211.94,45,214,45s3.31-2.14,3.31-12.76V21.89c0-10.63-1.24-12.76-3.31-12.76s-3.31,2.14-3.31,12.76Z" transform="translate(-113.48 -1.53)"/><path class="bp-pub-logo" d="M232.64,2.5h8.76l8.21,25.94h.14V2.5h7.18V51.63h-7l-9.59-29.74h-.14V51.63h-7.59Z" transform="translate(-113.48 -1.53)"/><path class="bp-pub-logo" d="M278.18,2.5h8.76l8.21,25.94h.14V2.5h7.18V51.63h-7l-9.59-29.74h-.14V51.63h-7.59Z" transform="translate(-113.48 -1.53)"/><path class="bp-pub-logo" d="M309.3,2.5h20.29v7.59H318.27V22.65h8.35v8h-8.35V44h11.8v7.59H309.3Z" transform="translate(-113.48 -1.53)"/><path class="bp-pub-logo" d="M332.35,2.5h8.14l3.17,28.84h.14L348.08,2.5h8.07l3.93,28.84h.14L363.74,2.5h6.42l-6.42,49.13H355.6l-4.28-31.12h-.14l-4.42,31.12H338.9Z" transform="translate(-113.48 -1.53)"/><path class="bp-pub-logo" d="M380.85,37.41c0,2.76,0,7.59,3.86,7.59,3,0,4-2.76,4-4.76,0-8.76-16.28-10.76-16.28-25.32,0-7.38,4-13.39,11.59-13.39,8.07,0,11.18,6.14,11.38,15h-8c0-2.76,0-7.38-3.59-7.38-2.14,0-3.38,1.79-3.38,4.48,0,8.35,16.28,11.18,16.28,25.46,0,7.52-4.28,13.52-12.35,13.52-9.59,0-11.52-8.42-11.52-15.18Z" transform="translate(-113.48 -1.53)"/></svg></a></div>
		</article>            <!--  -->
            <article id="text-33" class="small-4 medium-3 columns">
                <div id="weatherContainer" class="textwidget"></div>
            </article>
        </div>
        
        <!-- Mobile menu -->
        <nav id="site-navigation" class="main-navigation top-bar" role="navigation">
            <div class="top-bar-right row">
                                    
<nav class="vertical menu" id="mobile-menu" role="navigation">
    <ul id="menu-mainmenu-1" class="vertical menu accordion menu" data-accordion-menu><li class='nav-search'><a href='http://www.yukon-news.com/search/'><i class='fa fa-search menu'></i>Search</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-320"><a href="http://www.yukon-news.com/">Home</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-41562"><a href="http://www.yukon-news.com/submit/">Submit News Tip</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-169"><a href="http://www.yukon-news.com/./news/">News</a>
<ul class="vertical nested menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-170"><a href="http://www.yukon-news.com/./local-news/">Local</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-173"><a href="http://www.yukon-news.com/e-editions/">eEditions</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-176"><a href="http://www.yukon-news.com/submit/">Submit news tip or photo</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-177"><a href="http://www.yukon-news.com/./sports/">Sports</a>
<ul class="vertical nested menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-178"><a href="http://www.yukon-news.com/./local-sports/">Local</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-180"><a href="http://www.yukon-news.com/submit/">Submit sports tip or photo</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-181"><a href="http://www.yukon-news.com/./buzz/">Buzz</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-182"><a href="http://www.yukon-news.com/./business/">Business</a>
<ul class="vertical nested menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-183"><a href="http://www.yukon-news.com/./local-business/">Local</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-185"><a href="http://www.yukon-news.com/submit/">Submit business tip or photo</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-186"><a href="http://www.yukon-news.com/./entertainment/">Entertainment</a>
<ul class="vertical nested menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-187"><a href="http://www.yukon-news.com/./local-entertainment/">Local</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-189"><a href="http://www.yukon-news.com/submit/">Submit entertainment tip or photo</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-190"><a href="http://www.yukon-news.com/./life/">Life</a>
<ul class="vertical nested menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-191"><a href="http://www.yukon-news.com/./life/">Local</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-193"><a target="_blank" href="http://winetrails.ca">Wine Trails</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-194"><a href="http://www.yukon-news.com/submit/">Submit life tip or photo</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-195"><a href="http://www.yukon-news.com/./community/">Community</a>
<ul class="vertical nested menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-196"><a href="http://www.yukon-news.com/./community/">Local</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-197"><a href="http://www.yukon-news.com/calendar/">Calendar</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-198"><a href="http://www.yukon-news.com/submit/">Submit community tip or photo</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-282"><a href="http://www.yukon-news.com/./opinion/">Opinion</a>
<ul class="vertical nested menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-204"><a href="http://www.yukon-news.com/./opinion/">Local Opinion</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-35827"><a href="http://www.yukon-news.com/./wyatts-world/">Wyatt’s world</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-202"><a href="http://www.yukon-news.com/./editorials-opinion/">Editorials</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-201"><a href="http://www.yukon-news.com/./columns/">Columnists</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-203"><a href="http://www.yukon-news.com/./letters-opinions/">Letters</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-206"><a href="http://www.yukon-news.com/submitletters/">Submit letter</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-41442"><a href="http://www.yukon-news.com/./web-poll/">Web poll</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-210"><a href="http://www.yukon-news.com/videos/">Videos</a>
<ul class="vertical nested menu">
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-211"><a href="http://www.yukon-news.com/videos/">Local</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-212"><a href="http://www.yukon-news.com/submit/">Submit video</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-213"><a href="http://blackpress.tv">Black Press TV</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-214"><a href="http://www.yukon-news.com/weather/">Weather</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-41463"><a href="http://www.yukon-news.com/./obituaries/">Obituaries</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-13663"><a href="http://www.yukon-news.com/games/">Games</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-217"><a href="http://www.yukon-news.com/./marketplace/">Marketplace</a>
<ul class="vertical nested menu">
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-275"><a href="http://www.yukon-news.com/advertise/">Place an ad</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-218"><a href="http://www.yukon-news.com/./marketplace/">Impress branded content</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-222"><a href="http://blackpress4good.com">Crowdfunding</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-321"><a href="http://www.yukon-news.com/contests/">Contests</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-224"><a href="http://www.yukon-news.com/contact-us/">Contact Us</a>
<ul class="vertical nested menu">
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-225"><a href="http://www.yukon-news.com/contact-us/">Contact Us</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-226"><a href="http://www.yukon-news.com/our-team/">Our Team</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-230"><a href="http://blackpress.ca">Black Press</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-231"><a href="http://www.yukon-news.com/submit/">Submit tip or photo</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-227"><a href="http://www.yukon-news.com/faq/">FAQ</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-228"><a href="http://www.yukon-news.com/privacy-policy/">Privacy Policy</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-229"><a href="http://www.yukon-news.com/terms-of-use/">Terms of use</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-27623"><a href="#">Archive</a>
<ul class="vertical nested menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-27628"><a href="http://www.yukon-news.com/./multimedia/">Multimedia</a></li>
</ul>
</li>
</ul></nav>
                            </div>
        </nav>
        

    </header>

    <section class="container">
        <!-- Elevator: return to Top -->
        <a id="return-to-top" href="javascript:" ><i class="fa fa-chevron-up"></i></a>
        
        

<div id="single-post" role="main">

    <div class="row module ad">
        <div class="large-12 columns ad text-center">
            <div class='code-block code-block-30' style='margin: 8px 0; clear: both;'>
<!-- Obit leaderboard -->
<div id="div-gpt-30" class="gpt-ad">
<script type='text/javascript'>
    googletag.cmd.push(function() { googletag.display('div-gpt-30');gptRefreshSlots.push(30); });
</script>
</div></div>
        </div>
    </div>

    <!-- Number of attachments: 1 --><!-- Featured Image Layout: small -->

                <article class="main-content post-41798 post type-post status-publish format-standard has-post-thumbnail hentry category-obituaries" id="post-41798">

        
        <header>
            
                                    <h2 class="entry-title">Rita Fromme</h2>
            
            <ul class="author-meta"><li>Nov 17, 2017</li><li><a class="byline" href="http://www.yukon-news.com/obituaries/">Obituaries</a></li></ul>            <ul class="social story top">
	<li><span data-tooltip aria-haspopup="true" data-disable-hover="false" tabindex="1" title="Post to Facebook"><a href="http://www.facebook.com/sharer.php?u=http%3A%2F%2Fwww.yukon-news.com%2Fobituaries%2Frita-fromme%2F" class="social fa fa-facebook-f"></a></span></li>
	<li><span data-tooltip aria-haspopup="true" data-disable-hover="false" tabindex="1" title="Post to Twitter"><a href="http://twitter.com/home?status=Rita+Fromme+-+http%3A%2F%2Fwww.yukon-news.com%2Fobituaries%2Frita-fromme%2F" class="social fa fa-twitter"></a></span></li>
	<li><span data-tooltip aria-haspopup="true" data-disable-hover="false" tabindex="1" title="Post to Reddit"><a href="http://reddit.com/submit?url=http%3A%2F%2Fwww.yukon-news.com%2Fobituaries%2Frita-fromme%2F&title=Rita+Fromme" class="social fa fa-reddit-alien"></a></span></li>
	<li><span data-tooltip aria-haspopup="true" data-disable-hover="false" tabindex="1" title="Email story"><a href="mailto:?subject=Rita%20Fromme&ampsubject=Rita%20Fromme&amp;body=http%3A%2F%2Fwww.yukon-news.com%2Fobituaries%2Frita-fromme%2F" class="social fa fa-envelope-o"></a></span></li>
	<li><span data-tooltip aria-haspopup="true" data-disable-hover="false" tabindex="1" title="Print story"><a href="javascript:window.print();" class="social fa fa-print"></a></span></li>
	<li><span data-tooltip aria-haspopup="true" data-disable-hover="false" tabindex="1" title="Jump to comments"><a href="#facebook-comments" class="social fa fa-comment-o"></a></span></li>
</ul>
<div class="post-attachment medium"  alt="&lt;640"><img width="400" height="600" src="http://3gipq24d7ux62drxrjfr3ih1.wpengine.netdna-cdn.com/wp-content/uploads/2017/11/A7J0P6W6-20171117101316.jpg" class="attachment-full size-full" alt="" srcset="http://3gipq24d7ux62drxrjfr3ih1.wpengine.netdna-cdn.com/wp-content/uploads/2017/11/A7J0P6W6-20171117101316-200x300@2x.jpg 400w, http://3gipq24d7ux62drxrjfr3ih1.wpengine.netdna-cdn.com/wp-content/uploads/2017/11/A7J0P6W6-20171117101316-200x300.jpg 200w" sizes="(max-width: 1199px) 98vw, 400px" /><p></p></div>        </header>
                <div class="entry-content">

        <p><b>Nov 13, 1934 &#8211; Nov 17, 2017</b><br />Rita Fromme was the oldest of nine children raised on a small farm on the Gaspe Peninsula. Her father grew root vegetables cherries and apples. Though the family&#8217;s income was meagre, Rita remembered her parents as loving who provided their family with a good start in life.  She attended school (grades one to eleven) in a four room building. </p>
<p>Rita was a voracious reader attracted to fictional authors who could, like herself, tell a really good story.  One &#8220;Rita&#8221; story she weaved around her iconic story telling during family gatherings was her telling of the &#8220;hippy couple who were into yoga.&#8221; In the early 70&#8217;s Rita had occasion to rent an apartment in Vancouver. Across the hall were a young twenty something &#8220;hippy&#8221; couple  who liked Rita and invited her for tea.</p>
<p>When Rita arrived the young man was poised in the living room in a well known yoga position. Rita glanced his way for a bit, looked him up and down, and without flinching sat down to tea and crumpets.  She politely drank her tea and visited with the young lady.  After about fifteen minutes the hostess remarked her boyfriend was deeply committed to his yoga exercise. Rita, still without batting an eye, said &#8220;Ah, yes, that&#8217;s the crane isn&#8217;t it!&#8221; The man obviously believed clothes would hinder his free expression of the &#8220;crane pose&#8221; as he stood naked as a jay bird. </p>
<p>At seventeen, Rita started her nursing career and trained at the Montreal General. Nurses lived in residence with scant opportunity for entertainment.  But when they did go out on a date, the Matron of the Residence &#8211; &#8220;Cuddles&#8221; they called her, waited at the entrance until midnight curfew.  &#8220;Come In&#8221; she would yelp at any brave nurse who took too long to say good night.</p>
<p>Rita graduated from nursing school but returned to the Gaspe to nurse her Mother. When she was able to return to Montreal, she bunked with her sister, Della. One Saturday morning, the door bell rang.  Rita, in housecoat and curlers thought it was her sister  and chastised her, &#8220;Good Gracious Della, can&#8217;t you remember your key?&#8221;  When she opened the door she first set eyes on Gerry Fromme, who had come knocking to take  Della to a show. One thing lead to another and Rita recounted, &#8220;he was so persistent I eventually just accepted the inevitable.&#8221; Rita also told us more than once, there was no better place than Montreal in the early fifties for a passionate love affair.  </p>
<p>Gerry was in the Air Force stationed not far from Montreal and they courted for a couple of years.  Rather than be stationed in Germany they chose to move to Whitehorse, Gerry&#8217;s home town. Rita&#8217;s rendition of her decision to follow him was &#8220;Oh you know, whither thou goest I will go, plus she said she didn&#8217;t care one way or another&#8221;. They married November 29, 1958.</p>
<p>Their two sons Steven and Michael were born in 61 and 65 and moved from Whitehorse to Fairbanks, back to Whitehorse then to Vancouver to raise their sons. Rita and Gerry returned to Whitehorse in 1984 and eventually moved to their beautiful, quaint home overlooking Marsh Lake in Judas Creek. </p>
<p>Rita loved Judas Creek, and she loved retirement. Gerry worked with Corrections Yukon until he retired, Rita nursed at Whitehorse General, Thompson Center and McCauley before she retired. They were married fifty-six years when Gerry passed suddenly  in May 2014.  Rita could not manage on her own and the move away from Judas Creek was difficult for her, but typical Rita, pulled up her big girl panties, and created a lovely apartment with her blue and white color scheme and memorabilia accumulated over the years at Greenwood Place.  </p>
<p>A truly lovely woman is no exaggeration. The desserts that came from her kitchen are legendary: cream puffs, cakes, pies, cookies, plum pudding will never taste the same without her. Rita&#8217;s sense of humor and pragmatic approach to life&#8217;s vicissitudes was admired by many; but Rita&#8217;s devotion to Gerry and her family defined her.</p>
<p>Rita is survived by her two sons Stephen and Michael, daughter&#8217;s in law Joanne and Jeannie; grandchildren Michelle, Erin, Danielle and Clair and great grand children Tyler and Kaylin.   Rita left us on November 13th, ready to go, anxious to see Gerry and reap her just rewards.</p>
<p>Join us at 2:00 November 23rd in Christ Church Cathedral to say farewell to a wonderful wife, mother and friend.  </p>
<p>There is a reception in Hellaby Hall following the service.</p>
                        </div>

        <!-- BEGIN: FACE BOOK Comments -->
        

            <div>
<hr>
<style>.obituary-logo{float:left;height:60px;}.obituary-approve-text{font-size:15px;}.obituary-contact{text-decoration:underline;color:blue;}</style>
<svg class="obituary-logo" id="Layer_1" data-name="Layer 1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" viewBox="0 0 378.07 311.92"><defs><style>.cls-1{fill:url(#linear-gradient);}.cls-2{fill:url(#linear-gradient-2);}.cls-3{fill:url(#linear-gradient-3);}.cls-4{fill:url(#New_Gradient_Swatch_5);}.cls-5{fill:url(#radial-gradient);}.cls-6{fill:url(#New_Gradient_Swatch_5-2);}.cls-7{fill:url(#New_Gradient_Swatch_5-3);}.cls-8{fill:url(#New_Gradient_Swatch_5-4);}.cls-9{fill:url(#New_Gradient_Swatch_5-5);}.cls-10{fill:url(#radial-gradient-2);}.cls-11{fill:url(#radial-gradient-3);}.cls-12{fill:url(#linear-gradient-4);}.cls-13{fill:url(#New_Gradient_Swatch_10);}.cls-14{fill:url(#radial-gradient-4);}.cls-15{fill:url(#linear-gradient-5);}.cls-16{fill:url(#linear-gradient-6);}.cls-17{fill:url(#radial-gradient-5);}.cls-18{fill:url(#radial-gradient-6);}.cls-19{fill:url(#New_Gradient_Swatch_5-6);}.cls-20{fill:url(#radial-gradient-7);}.cls-21{fill:url(#radial-gradient-8);}.cls-22{fill:url(#radial-gradient-9);}.cls-23{fill:url(#radial-gradient-10);}.cls-24{fill:url(#radial-gradient-11);}.cls-25{fill:url(#radial-gradient-12);}.cls-26{fill:url(#radial-gradient-13);}.cls-27{fill:url(#radial-gradient-14);}.cls-28{fill:url(#radial-gradient-15);}.cls-29{fill:url(#radial-gradient-16);}</style><linearGradient id="linear-gradient" x1="102.66" y1="443.29" x2="287.43" y2="443.29" gradientTransform="translate(-105.03 -332.13) scale(1.02 1.37)" gradientUnits="userSpaceOnUse"><stop offset="0" stop-color="#bd9238"></stop><stop offset="0.32" stop-color="#825e2d"></stop><stop offset="0.72" stop-color="#180000"></stop></linearGradient><linearGradient id="linear-gradient-2" x1="-288.12" y1="443.29" x2="-103.35" y2="443.29" gradientTransform="matrix(-1.02, 0, 0, 1.37, 83.3, -332.13)" xlink:href="#linear-gradient"></linearGradient><linearGradient id="linear-gradient-3" x1="47.86" y1="155.98" x2="329.12" y2="155.98" gradientUnits="userSpaceOnUse"><stop offset="0.04" stop-color="#5d3e1f"></stop><stop offset="0.3" stop-color="#bd9238"></stop><stop offset="0.5" stop-color="#f4db74"></stop><stop offset="0.69" stop-color="#bd9238"></stop><stop offset="1" stop-color="#5d3e1f"></stop></linearGradient><linearGradient id="New_Gradient_Swatch_5" x1="188.49" y1="23.61" x2="188.49" y2="278.18" gradientUnits="userSpaceOnUse"><stop offset="0.01" stop-color="#78552b"></stop><stop offset="0.25" stop-color="#bd9238"></stop><stop offset="0.5" stop-color="#f4db74"></stop><stop offset="0.75" stop-color="#bd9238"></stop><stop offset="1" stop-color="#78552b"></stop></linearGradient><radialGradient id="radial-gradient" cx="188.49" cy="155.98" r="126.93" gradientUnits="userSpaceOnUse"><stop offset="0.41" stop-color="#f4db74"></stop><stop offset="0.63" stop-color="#bd9238"></stop><stop offset="0.73" stop-color="#ba8f37"></stop><stop offset="0.82" stop-color="#af8635"></stop><stop offset="0.89" stop-color="#9e7732"></stop><stop offset="0.97" stop-color="#86622e"></stop><stop offset="1" stop-color="#78552b"></stop></radialGradient><linearGradient id="New_Gradient_Swatch_5-2" x1="248.57" y1="95.9" x2="248.57" y2="215.86" xlink:href="#New_Gradient_Swatch_5"></linearGradient><linearGradient id="New_Gradient_Swatch_5-3" x1="128.41" y1="95.9" x2="248.57" y2="95.9" xlink:href="#New_Gradient_Swatch_5"></linearGradient><linearGradient id="New_Gradient_Swatch_5-4" x1="128.41" y1="95.9" x2="128.41" y2="215.86" xlink:href="#New_Gradient_Swatch_5"></linearGradient><linearGradient id="New_Gradient_Swatch_5-5" x1="128.41" y1="216.06" x2="248.57" y2="216.06" xlink:href="#New_Gradient_Swatch_5"></linearGradient><radialGradient id="radial-gradient-2" cx="287.82" cy="289.82" r="169.48" gradientUnits="userSpaceOnUse"><stop offset="0.06" stop-color="#005384"></stop><stop offset="0.43" stop-color="#00314e"></stop><stop offset="1"></stop></radialGradient><radialGradient id="radial-gradient-3" cx="347.7" cy="237.86" r="25.52" gradientTransform="translate(-21.29 -229.99) scale(0.6 1.33)" gradientUnits="userSpaceOnUse"><stop offset="0" stop-color="#fff"></stop><stop offset="0.2" stop-color="#ffea0e"></stop><stop offset="0.48" stop-color="#ea9526"></stop><stop offset="0.51" stop-color="#d28e2f"></stop><stop offset="0.58" stop-color="#9b7d44"></stop><stop offset="0.65" stop-color="#6c6f57"></stop><stop offset="0.73" stop-color="#456465"></stop><stop offset="0.8" stop-color="#275b71"></stop><stop offset="0.87" stop-color="#115479"></stop><stop offset="0.94" stop-color="#04507e"></stop><stop offset="1" stop-color="#004f80"></stop></radialGradient><linearGradient id="linear-gradient-4" x1="289.36" y1="267.55" x2="289.36" y2="314.11" gradientUnits="userSpaceOnUse"><stop offset="0" stop-color="#fff8a9"></stop><stop offset="0.46" stop-color="#fff204"></stop><stop offset="0.73" stop-color="#ffcd1f"></stop><stop offset="1" stop-color="#f6ba23"></stop></linearGradient><linearGradient id="New_Gradient_Swatch_10" x1="289.36" y1="294.91" x2="289.36" y2="314.11" gradientUnits="userSpaceOnUse"><stop offset="0.05" stop-color="#ffcd1f"></stop><stop offset="1" stop-color="#eca325"></stop></linearGradient><radialGradient id="radial-gradient-4" cx="188.68" cy="122.31" r="1.1" gradientUnits="userSpaceOnUse"><stop offset="0" stop-color="#f2efea"></stop><stop offset="1" stop-color="#dfd9cc"></stop></radialGradient><linearGradient id="linear-gradient-5" x1="262.48" y1="409.34" x2="316.7" y2="409.34" gradientUnits="userSpaceOnUse"><stop offset="0.01" stop-color="#dfd9cc"></stop><stop offset="0.12" stop-color="#d2cab8"></stop><stop offset="0.36" stop-color="#ebe7df"></stop><stop offset="0.5" stop-color="#fff"></stop><stop offset="0.86" stop-color="#e1dbcf"></stop><stop offset="0.92" stop-color="#f2efeb"></stop><stop offset="1" stop-color="#d8d0c0"></stop></linearGradient><linearGradient id="linear-gradient-6" x1="262.48" y1="331.18" x2="316.7" y2="331.18" gradientUnits="userSpaceOnUse"><stop offset="0.01" stop-color="#dfd9cc"></stop><stop offset="0.5" stop-color="#fff"></stop><stop offset="1" stop-color="#dfd9cc"></stop></linearGradient><radialGradient id="radial-gradient-5" cx="289.85" cy="322.3" r="6.09" xlink:href="#radial-gradient-4"></radialGradient><radialGradient id="radial-gradient-6" cx="289.41" cy="349.24" r="155.96" gradientUnits="userSpaceOnUse"><stop offset="0.86" stop-color="#4a3419"></stop><stop offset="0.94" stop-color="#bd9238"></stop><stop offset="0.97" stop-color="#f4db74"></stop><stop offset="0.98" stop-color="#bd9238"></stop><stop offset="1" stop-color="#78552b"></stop></radialGradient><linearGradient id="New_Gradient_Swatch_5-6" x1="123.03" y1="426.47" x2="445.27" y2="426.47" gradientTransform="translate(-105.03 -332.13) scale(1.02 1.37)" xlink:href="#New_Gradient_Swatch_5"></linearGradient><radialGradient id="radial-gradient-7" cx="292.49" cy="442.22" r="114.11" gradientUnits="userSpaceOnUse"><stop offset="0.08" stop-color="#81602c"></stop><stop offset="0.66" stop-color="#3c2a12"></stop></radialGradient><radialGradient id="radial-gradient-8" cx="292.49" cy="442.22" r="114.11" xlink:href="#radial-gradient-7"></radialGradient><radialGradient id="radial-gradient-9" cx="292.49" cy="442.22" r="114.11" xlink:href="#radial-gradient-7"></radialGradient><radialGradient id="radial-gradient-10" cx="292.49" cy="442.22" r="114.11" xlink:href="#radial-gradient-7"></radialGradient><radialGradient id="radial-gradient-11" cx="292.49" cy="442.22" r="114.11" xlink:href="#radial-gradient-7"></radialGradient><radialGradient id="radial-gradient-12" cx="292.49" cy="442.22" r="114.11" xlink:href="#radial-gradient-7"></radialGradient><radialGradient id="radial-gradient-13" cx="292.49" cy="442.22" r="114.1" xlink:href="#radial-gradient-7"></radialGradient><radialGradient id="radial-gradient-14" cx="292.49" cy="442.22" r="114.11" xlink:href="#radial-gradient-7"></radialGradient><radialGradient id="radial-gradient-15" cx="292.49" cy="442.22" r="114.1" xlink:href="#radial-gradient-7"></radialGradient><radialGradient id="radial-gradient-16" cx="292.49" cy="442.22" r="114.11" xlink:href="#radial-gradient-7"></radialGradient></defs><title>InMemoriumLogo</title><polygon class="cls-1" points="33.43 272.11 0 251.52 124.97 251.52 189.03 295.55 21.88 295.55 33.43 272.11"></polygon><polygon class="cls-2" points="344.64 272.11 378.07 251.52 253.1 251.52 189.03 295.55 356.19 295.55 344.64 272.11"></polygon><circle class="cls-3" cx="188.49" cy="155.98" r="140.63"></circle><circle class="cls-4" cx="188.49" cy="155.98" r="132.37"></circle><circle class="cls-5" cx="188.49" cy="155.98" r="126.93"></circle><circle class="cls-6" cx="248.57" cy="155.98" r="60.08"></circle><circle class="cls-7" cx="188.49" cy="95.9" r="60.08"></circle><circle class="cls-8" cx="128.41" cy="155.98" r="60.08"></circle><circle class="cls-9" cx="188.49" cy="216.06" r="60.08"></circle><path class="cls-10" d="M349.44,299.19a50.17,50.17,0,0,0-11.31,1.3,50.06,50.06,0,1,0-97.53,0,50.06,50.06,0,1,0,0,97.53,50.07,50.07,0,1,0,97.53,0,50.06,50.06,0,1,0,11.31-98.83Z" transform="translate(-100.87 -193.28)"></path><ellipse class="cls-11" cx="189.04" cy="85.68" rx="15.44" ry="33.86"></ellipse><path class="cls-12" d="M282.82,300.44c0-7.55,2.93-32.89,6.54-32.89s6.54,25.34,6.54,32.89-2.93,13.67-6.54,13.67S282.82,308,282.82,300.44Z" transform="translate(-100.87 -193.28)"></path><path class="cls-13" d="M286.66,308.47c0-3.11,1.21-13.57,2.7-13.57s2.7,10.45,2.7,13.57-1.21,5.64-2.7,5.64S286.66,311.59,286.66,308.47Z" transform="translate(-100.87 -193.28)"></path><rect class="cls-14" x="188.49" y="120.83" width="0.38" height="6.65"></rect><path class="cls-15" d="M289.59,328.71c-15,0-27.11,2-27.11,4.41V487.47a145.35,145.35,0,0,0,54.22-.09V333.13C316.7,330.69,304.56,328.71,289.59,328.71Z" transform="translate(-100.87 -193.28)"></path><path class="cls-16" d="M289.59,328.71c-15,0-27.11,2-27.11,4.41v.52c0-2.31,12.14-4.18,27.11-4.18s27.11,1.87,27.11,4.18v-.52C316.7,330.69,304.56,328.71,289.59,328.71Z" transform="translate(-100.87 -193.28)"></path><path class="cls-17" d="M289.59,328.71c13.9,0,25.35,1.7,26.92,3.9-1.18-3.88-10.77-3.23-21-10.94-3.68-2.78-6-2.31-6-2.31s-2.31-.47-6,2.31c-10.3,7.77-20,7-21,11l.07,0C263.85,330.47,275.46,328.71,289.59,328.71Z" transform="translate(-100.87 -193.28)"></path><path class="cls-18" d="M133.45,349.24a156,156,0,1,1,156,156A156,156,0,0,1,133.45,349.24ZM289.36,489.89A140.63,140.63,0,1,0,148.73,349.26,140.63,140.63,0,0,0,289.36,489.89Z" transform="translate(-100.87 -193.28)"></path><polygon class="cls-19" points="20.84 228.53 350.52 228.53 328.91 272.56 42.72 272.56 20.84 228.53"></polygon><path class="cls-20" d="M181.34,429.38h11.21l-.15.68h-4l-5.36,25.45h4l-.19.68H175.68l.11-.68h4l5.36-25.45h-4Z" transform="translate(-100.87 -193.28)"></path><path class="cls-21" d="M197.34,438.35l-2.09,10.14c1.1-2.73,2.39-5.81,4.67-8.05a6,6,0,0,1,4.63-2.05c2.62,0,4.71,1.48,4.71,4.14a11.75,11.75,0,0,1-.27,2l-1.94,7.22a9.69,9.69,0,0,0-.38,2.51c0,.83.42,1.48,1.25,1.48,1.1,0,1.9-1.37,2.7-4.06l.53.11c-.72,2.62-1.63,4.94-4.14,4.94a3.05,3.05,0,0,1-3.15-3.31,12.1,12.1,0,0,1,.34-2.39l1.75-6.61a9.83,9.83,0,0,0,.38-2.35,2.53,2.53,0,0,0-2.7-2.85c-2.58,0-4.41,2.89-5.09,3.91-2.51,3.91-3.84,8.58-4.94,13.11h-3l3.5-16.79-3.38.53-.11-.57Z" transform="translate(-100.87 -193.28)"></path><path class="cls-22" d="M225.73,429.38h7.48l6.53,14.13,13.45-14.13h7.48l-.15.68h-4l-5.43,25.45h4l-.15.68H243.66l.15-.68,4.07,0,5.36-25.19-13.26,14a15.5,15.5,0,0,1,1.06,5.43c0,4.82-2.47,7.18-4.67,7.18-1.33,0-3-.95-3-3.46a9.4,9.4,0,0,1,2.28-5.32l1.71-2.13-7-15.31-5.24,24.77H229l-.15.68H220l.15-.68,4,0,5.39-25.49h-4Zm8.4,24.08c0,1.9,1.18,2.77,2.24,2.77.68,0,2.81-.57,2.81-3.87a13.11,13.11,0,0,0-1.44-5.58C236.59,448.07,234.12,450.89,234.12,453.47Z" transform="translate(-100.87 -193.28)"></path><path class="cls-23" d="M271.63,452.33c-1.06,1.52-3.08,4.52-7.29,4.52-3.42,0-6-2.2-6-6.42a14.21,14.21,0,0,1,2-6.8c1.79-3.08,4.86-5.2,8-5.2,2.66,0,4.63,1.71,4.63,4.22a5.94,5.94,0,0,1-1.82,4.21c-2.47,2.51-5.81,2.51-7.18,2.51-.76,0-1.56,0-2.36-.08a14.07,14.07,0,0,0-.11,1.79c0,2.54,1.06,5.09,3.72,5.09,3.23,0,5.2-3,6-4.1Zm-8.4-3.53c5.28,0,8.58-3.15,8.58-6.5a2.86,2.86,0,0,0-2.92-3.16,4.58,4.58,0,0,0-3.27,1.6c-2.74,2.66-3.61,6.27-4,8C262.17,448.76,262.7,448.79,263.23,448.79Z" transform="translate(-100.87 -193.28)"></path><path class="cls-24" d="M281.39,438.35l-2.13,10.22c1.52-3.72,4.29-10.22,9.16-10.22a3.74,3.74,0,0,1,4.07,3.87,8.46,8.46,0,0,1-.23,1.67l-1,4.56c1.6-3.88,4.22-10.07,9-10.07,3.65,0,4.29,2.54,4.29,3.91a11,11,0,0,1-.53,2.81l-1.82,6.61a9.44,9.44,0,0,0-.38,2.28c0,.42,0,1.71,1.25,1.71s2-1.9,2.7-4.06l.57.11c-.72,2.32-1.52,4.94-4.22,4.94-1.4,0-3.11-.84-3.11-3.46a10.54,10.54,0,0,1,.42-2.47l2-7.14a9.55,9.55,0,0,0,.34-2.09,2.14,2.14,0,0,0-2.24-2.36c-2.66,0-6.76,3.76-10,17h-2.89l2.66-12.69a7.16,7.16,0,0,0,.27-1.78c0-1.75-1-2.47-2.16-2.47-.38,0-2.24,0-4.56,3.49-2.93,4.37-4.44,10.29-5.24,13.45h-2.85l3.5-16.75-3.38.53-.15-.61Z" transform="translate(-100.87 -193.28)"></path><path class="cls-25" d="M325.58,445.95c0,4.06-2.77,10.94-9.84,10.94-3.53,0-7.52-1.94-7.52-7.48,0-5.05,3.5-10.87,9.61-11C322.13,438.27,325.58,441,325.58,445.95Zm-7.22-7c-3,0-4.25,2.4-4.75,3.27a23.28,23.28,0,0,0-2.32,9c0,3,1.52,5.13,4.22,5.13s3.87-1.86,4.6-3.31a21.26,21.26,0,0,0,2.32-8.85,7.79,7.79,0,0,0-.53-3A3.7,3.7,0,0,0,318.37,439Z" transform="translate(-100.87 -193.28)"></path><path class="cls-26" d="M333,448.68c1.75-4.22,4.82-10.45,8.13-10.45a2.25,2.25,0,0,1,2.32,2.17,2.09,2.09,0,0,1-2.12,2.09,2.07,2.07,0,0,1-2.09-2.21,4.69,4.69,0,0,1,.08-.76c-5.21,4.75-7.1,13-7.94,16.68h-2.93l3.5-16.71-3.34.45,0-.57,6.65-1Z" transform="translate(-100.87 -193.28)"></path><path class="cls-27" d="M350.85,438.42c-.65,3.08-1.22,5.74-2.24,9.5a37.58,37.58,0,0,0-1.41,6.19c0,.88.38,1.67,1.22,1.67,1.52,0,2.43-3.19,2.7-4.1l.57.15c-.76,2.43-1.63,4.9-4.18,4.9a3,3,0,0,1-3.12-3.3,20.79,20.79,0,0,1,1-4.82c1.25-4.63,2.05-7.64,2.39-9.19l-3.42.57-.11-.57Zm-2.32-6.53a1.95,1.95,0,1,1,.57,1.37A2.09,2.09,0,0,1,348.53,431.89Z" transform="translate(-100.87 -193.28)"></path><path class="cls-28" d="M366.58,448.23c-1.79,4.06-3.87,8.51-8,8.51-3,0-4.86-2.7-4.86-6.15a12.4,12.4,0,0,1,3.57-8.36,14.37,14.37,0,0,1,10-3.84,13,13,0,0,1,4.33.72L368.71,452a12.22,12.22,0,0,0-.34,2.24c0,.23,0,1.63,1.25,1.63,1.48,0,2.28-2.47,2.7-4.06l.57.15c-.72,2.81-1.67,4.9-4.1,4.9a3.09,3.09,0,0,1-3.19-3.27,7.36,7.36,0,0,1,.19-1.56Zm.76-9.23a9.49,9.49,0,0,0-4,1c-5.09,2.51-6.53,8.47-6.53,11.25s1.29,4.52,2.92,4.52c2.43,0,5-4,6.84-9.08a37.17,37.17,0,0,0,1.94-7.6C368.14,439,367.72,439,367.34,439Z" transform="translate(-100.87 -193.28)"></path><path class="cls-29" d="M381.55,438.35l-2.12,10.22c1.52-3.72,4.29-10.22,9.16-10.22a3.73,3.73,0,0,1,4.06,3.87,8.25,8.25,0,0,1-.23,1.67l-1,4.56c1.59-3.88,4.21-10.07,9-10.07,3.65,0,4.29,2.54,4.29,3.91a10.94,10.94,0,0,1-.53,2.81l-1.82,6.61A9.49,9.49,0,0,0,402,454c0,.42,0,1.71,1.25,1.71s2-1.9,2.7-4.06l.57.11c-.72,2.32-1.52,4.94-4.22,4.94-1.41,0-3.12-.84-3.12-3.46a10.49,10.49,0,0,1,.42-2.47l2-7.14a9.57,9.57,0,0,0,.34-2.09,2.14,2.14,0,0,0-2.24-2.36c-2.66,0-6.76,3.76-10,17h-2.89l2.66-12.69a7.25,7.25,0,0,0,.27-1.78c0-1.75-1-2.47-2.17-2.47-.38,0-2.24,0-4.56,3.49-2.93,4.37-4.44,10.29-5.24,13.45H374.9l3.49-16.75-3.38.53-.15-.61Z" transform="translate(-100.87 -193.28)"></path></svg>
<span class="obituary-approve-text">Your condolences will be approved within one business day. You will need a <a href="https://www.facebook.com/help/570785306433644/?helpref=hc_fnav" class="obituary-contact" target="_blank">valid Facebook account</a>. Please <a href="mailto:digitalobits@blackpress.ca" class="obituary-contact">email us</a> if you have any questions.</span>
    </div>
<div class="fb-comments" id="facebook-comments" data-href="http://www.yukon-news.com/obituaries/rita-fromme/" data-width="100%" data-numposts="10" data-order-by="reverse_time" data-colorscheme="light"></div>
        <!-- END: FACE BOOK Comments -->

        <footer>
                    </footer>
                
        <!-- Comments disabled for now -->
        <!-- <a class="hollow expanded button comments day-" href="">View Comments <i class="fa fa-comment-o"></i></a> -->
        
                
                
        <div class="row">
            <a class="button expanded" href="http://www.yukon-news.com/obituaries/" >Go Back To Obituaries</a>
        </div> 
        
    </article>

<aside class="sidebar"><div class='code-block code-block-32' style='margin: 8px 0; clear: both;'>
<!-- Obit sidebar -->
<div id="div-gpt-32" class="gpt-ad">
<script type='text/javascript'>
    googletag.cmd.push(function() { googletag.display('div-gpt-32');gptRefreshSlots.push(32); });
</script>
</div></div>
<div class='code-block code-block-33' style='margin: 8px 0; clear: both;'>
<!-- Obit sidebar -->
<div id="div-gpt-33" class="gpt-ad">
<script type='text/javascript'>
    googletag.cmd.push(function() { googletag.display('div-gpt-33');gptRefreshSlots.push(33); });
</script>
</div></div>
<div class='code-block code-block-34' style='margin: 8px 0; clear: both;'>
<!-- Obit sidebar -->
<div id="div-gpt-34" class="gpt-ad">
<script type='text/javascript'>
    googletag.cmd.push(function() { googletag.display('div-gpt-34');gptRefreshSlots.push(34); });
</script>
</div></div>
</aside></div>



        </section>
        <div id="footer-container">
            <footer id="footer">
                
                <div id="bp-logo" class="row">

    <div class="small-12 columns">
 
    <!-- *** BEGIN LOGO *** -->
        <div class="textwidget">
            <a class="pub-logo-small day-7" href="http://www.yukon-news.com/"><svg id="Outline" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 283.24 51.06"><defs><style>.cls-1{fill:#231f20;}</style></defs><title></title><path class="bp-pub-logo" d="M121.69,32.65,113.48,2.5h8.9l4.28,19.25h.14L131.35,2.5h7.52l-8.21,29.33v19.8h-9Z" transform="translate(-113.48 -1.53)"/><path class="bp-pub-logo" d="M141.63,2.5h9v38c0,2.21.48,4.49,3.1,4.49S157,42.86,157,40.52V2.5h7.59V39.34c0,9.66-4.28,13.25-11.45,13.25-6.9,0-11.52-3.59-11.52-13.25Z" transform="translate(-113.48 -1.53)"/><path class="bp-pub-logo" d="M171.44,2.5h9V23.06h.14L188,2.5h8L189.31,19l8.07,32.64h-8.62l-5-22h-.14l-3.24,7.73V51.63h-9Z" transform="translate(-113.48 -1.53)"/><path class="bp-pub-logo" d="M214,1.53c7.94,0,13.11,6.14,13.11,25.53S222,52.59,214,52.59,200.9,46.45,200.9,27.06,206.08,1.53,214,1.53ZM210.7,32.24C210.7,42.86,211.94,45,214,45s3.31-2.14,3.31-12.76V21.89c0-10.63-1.24-12.76-3.31-12.76s-3.31,2.14-3.31,12.76Z" transform="translate(-113.48 -1.53)"/><path class="bp-pub-logo" d="M232.64,2.5h8.76l8.21,25.94h.14V2.5h7.18V51.63h-7l-9.59-29.74h-.14V51.63h-7.59Z" transform="translate(-113.48 -1.53)"/><path class="bp-pub-logo" d="M278.18,2.5h8.76l8.21,25.94h.14V2.5h7.18V51.63h-7l-9.59-29.74h-.14V51.63h-7.59Z" transform="translate(-113.48 -1.53)"/><path class="bp-pub-logo" d="M309.3,2.5h20.29v7.59H318.27V22.65h8.35v8h-8.35V44h11.8v7.59H309.3Z" transform="translate(-113.48 -1.53)"/><path class="bp-pub-logo" d="M332.35,2.5h8.14l3.17,28.84h.14L348.08,2.5h8.07l3.93,28.84h.14L363.74,2.5h6.42l-6.42,49.13H355.6l-4.28-31.12h-.14l-4.42,31.12H338.9Z" transform="translate(-113.48 -1.53)"/><path class="bp-pub-logo" d="M380.85,37.41c0,2.76,0,7.59,3.86,7.59,3,0,4-2.76,4-4.76,0-8.76-16.28-10.76-16.28-25.32,0-7.38,4-13.39,11.59-13.39,8.07,0,11.18,6.14,11.38,15h-8c0-2.76,0-7.38-3.59-7.38-2.14,0-3.38,1.79-3.38,4.48,0,8.35,16.28,11.18,16.28,25.46,0,7.52-4.28,13.52-12.35,13.52-9.59,0-11.52-8.42-11.52-15.18Z" transform="translate(-113.48 -1.53)"/></svg></a>        </div>

    <!-- *** END LOGO *** -->
    </div>            
        
</div><!-- row -->

<div id="bp-social-footer" class="row">
    <div class="small-12 columns">
                    
        <div class="textwidget">
            <ul class="social footer">
	<li><a title="Follow us on Facebook" class="social fa fa-facebook-f" href="https://www.facebook.com/yukonnews/?fref=ts" target="_blank"></a></li>
	<li><a title="Follow us on Twitter" class="social fa fa-twitter" href="https://twitter.com/yukon_news" target="_blank"></a></li>
	<!--<li><a title="Follow us on Instagram" class="social fa fa-instagram" href="#"  target="_blank"></a></li>
	 <li><a title="RSS Feed" class="social fa fa-rss" href="/feed/"></a></li> -->
<li><a title="Submit a story" href="/submit/">
            <img style="margin-bottom:0;width: 34px;height: 34px;" 
            src="http://3gipq24d7ux62drxrjfr3ih1.wpengine.netdna-cdn.com/wp-content/themes/BlackPress/assets/images/submit.png"></a>
            </li></ul>        </div>

    </div>
</div><!-- row -->

<div id="bp-site-map-title" class="row" >
    <div class="small-12 columns" >
                
        <div class="textwidget" >        
             <h4 class="text-left">Explore Yukon News</h4>
        </div>

    </div>
</div>   

<div id="bp-site-map" class="row" >
    <div id="bp-site-map-list-1" class="small-6 columns">
       
            <div  class="large-3 columns">
                        
                <ul>
                    <li><a href="/news/">NEWS</a></li>
                    <li><a href="/sports/">SPORTS</a></li>
                    <li><a href="/buzz/">BUZZ</a></li>
                    
                </ul>

            </div>
            <div  class="large-5 columns">
                        
                <ul >
                    <li><a href="/business/">BUSINESS</a></li>
                    <li><a href="/entertainment/">ENTERTAINMENT</a></li>
                    <li><a href="/life/">LIFE</a></li>
                    
                </ul>

            </div>

            <div class="large-4 columns">
                        
                <ul >
                    <li><a href="/community/">COMMUNITY</a></li>
                    <li><a href="/opinion/">OPINION</a></li>
                    <li><a href="/video/" class="show-for-large">VIDEOS</a></li>
                </ul>

            </div>
        
    </div>
     <div id="bp-site-map-list-2" class="small-6 columns" >
        
            <div class="large-6 columns">
                        
                <ul>
                    <li><a href="/video/" class="hide-for-large">VIDEOS</a></li>
                    <li><a href="/weather/">WEATHER</a></li>
                    <li><a href="/obituaries/">OBITUARIES</a></li>
                    <li><a href="/e-editions/">SPECIAL SECTIONS</a></li>
                </ul>

            </div>
            <div class="large-6 columns">
                        
                <ul>
                <li><a href="/marketplace/">MARKETPLACE</a></li>
                    <li><a href="/contests/">CONTESTS</a></li>
                    <li><a href="/contact-us/">CONTACT US</a></li>
                </ul>

            </div>
        
    </div>
</div><!-- row -->

<div id="bp-media-group" class="row" >
    
    <div class="small-12 columns">
                
        <div class="textwidget">
            
                <a href="//www.blackpress.ca/publications/">BLACK PRESS MEDIA</a>      
           
        </div>

    </div>
    
    <div class="small-12 columns menu-footer-container">
        <ul id="menu-footer" class="menu" >
            
                    
        
        </ul>
        
    </div>
</div><!-- row -->

<div id="bp-terms" class="row" >
    
    <div class="small-12 columns">
        
        <ul id="menu-footer" class="menu">
            
            <li class="menu-item"><a target="_blank"href="http://www.yukon-news.com/contact-us/">Contact Us</a></li><li class="menu-item"><a target="_blank"href="http://www.yukon-news.com/our-team/">Our Team</a></li><li class="menu-item"><a target="_blank"href="http://www.yukon-news.com/privacy-policy/">Privacy Policy</a></li><li class="menu-item"><a target="_blank"href="http://www.yukon-news.com/terms-of-use/">Terms of use</a></li><li class="menu-item"><a target="_blank"href="http://www.yukon-news.com/./local-news/">Yukon News</a></li><li class="menu-item"><a target="_blank"href="http://www.yukon-news.com/weather/">Yukon Weather</a></li><li class="menu-item"><a target="_blank"href="/classifieds/">Yukon Classifieds</a></li>      
        </ul>

    </div>

    <div class="small-12 columns">
                
        <div class="textwidget">
            &copy; 2017, <a href="#"></a>Yukon News and <a href="http://www.blackpress.ca/">Black Press Group Ltd.</a>
        </div>

    </div>
</div><!-- row -->

                            </footer>
        </div>

        


<!-- Start Catfish ad -->
<div style="position:fixed;bottom:0px;width:100%;background:white;">
<div id="div-gpt-17" class="gpt-ad" style="margin: 0 auto;width:320px;">
<script type='text/javascript'>
    googletag.cmd.push(function() { googletag.display('div-gpt-17');gptRefreshSlots.push(17); });
</script>
</div>
</div>
<!-- End Catfish ad -->


<!-- Start Interstitial ad -->
<div id='page-cover' style="z-index:999999; text-align:center;background-color:#FFF; position:fixed; top:0; left:0; width:100%; height:100%;padding-top: 25%;padding-left: 10px;padding-right: 10px;display: none;">  
<div id="div-gpt-18" class="gpt-ad">
<script type='text/javascript'>
  googletag.cmd.push(function() { googletag.display('div-gpt-18');gptRefreshSlots.push(18);googletag.pubads().addEventListener('slotRenderEnded', function(event) {
                if (event.slot === gptAdSlots[18]) {
                    if(event.isEmpty) {
                        document.getElementById("page-cover").style.display = 'none';
                    }
                    else{
                        console.log("setting timer")
                    	//delay modal window from opening to allow ad tags to render; the above listener means the tags loaded, not necessarily showing the creative.
                    	var delayModal = window.setTimeout(
                    		function(){var timeoutID = window.setTimeout(function(){document.getElementById("page-cover").style.display = 'none';},8000);document.getElementById("page-cover").style.display = 'block';}
                    	,5000);
                    }
                }
            });
  });
  $(document).ready(function() {
    	$("#close-interstitial").click(function() {
        	document.getElementById("page-cover").style.display = 'none';
    	});
	}); 
</script>
</div>
<div><a id="close-interstitial" href="#">Close ad</a></div>
</div>
<!-- End Interstitial ad -->
<!-- Start vendor library call -->
<!-- /1036919/vendor_library_0 -->
<div id='div-gpt-21' style='height:1px; width:1px;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-21');gptRefreshSlots.push(21); });
</script>
</div>
<!-- End vendor library call -->
<script type='text/javascript'>
    googletag.cmd.push(function() {
        for (i = 0; i < gptAdSlots.length; i++) { 
            if(gptRefreshSlots.indexOf(i) == -1){                
                googletag.destroySlots([gptAdSlots[i]]);
                console.log('destroyed ' + i);
            }
        }
        googletag.pubads().refresh(gptAdSlots);
    });
</script><script type='text/javascript' src='//content.jwplatform.com/libraries/22ZiKJyA.js?ver=1.0.0'></script>
<script type='text/javascript' src='http://3gipq24d7ux62drxrjfr3ih1.wpengine.netdna-cdn.com/wp-content/themes/BlackPress/assets/components/featherlight/featherlight.js?ver=1.6.1'></script>
<script type='text/javascript' src='http://3gipq24d7ux62drxrjfr3ih1.wpengine.netdna-cdn.com/wp-content/themes/BlackPress/dest/javascript/foundation.min.js?ver=2.0.3'></script>
<script type='text/javascript' src='http://3gipq24d7ux62drxrjfr3ih1.wpengine.netdna-cdn.com/wp-content/themes/BlackPress/dest/javascript/what-input/what-input.min.js?ver=4.0.3'></script>
<script type='text/javascript' src='http://3gipq24d7ux62drxrjfr3ih1.wpengine.netdna-cdn.com/wp-content/themes/BlackPress/dest/javascript/frame_resize_2.0.min.js?ver=2.0.3'></script>
<script type='text/javascript' src='http://3gipq24d7ux62drxrjfr3ih1.wpengine.netdna-cdn.com/wp-includes/js/comment-reply.min.js?ver=4.8.3'></script>
<script type='text/javascript' src='http://3gipq24d7ux62drxrjfr3ih1.wpengine.netdna-cdn.com/wp-includes/js/wp-embed.min.js?ver=4.8.3'></script>
</body>
</html>




