<!DOCTYPE html>
<html class="no-js no-slidemenu letters-opinions">
<head>
	<meta charset="utf-8">
	<title>Problems with legal aid | Yukon News</title>
<meta property="og:image" content="" />
<meta property="og:description" content="I have several children with different moms here in Whitehorse. I have been having difficulties with some of the mothers providing me with adequate visitation or none at all." />
		
	<meta name="viewport" content="width=device-width, initial-scale=1">
	<meta name="apple-mobile-web-app-capable" content="yes">
	<meta name="apple-mobile-web-app-status-bar-style" content="black">
	<link rel="apple-touch-icon-precomposed" href="http://www.yukon-news.com/assets/icons/yn_touch_icn_512px.png">
	
	<link rel="shortcut icon" href="/assets/icons/favicon.ico" type="image/x-icon">
    <link rel="icon" href="/assets/icons/favicon.ico" type="image/x-icon">	
	<link href='http://fonts.googleapis.com/css?family=Open+Sans:400italic,600italic,400,600' rel='stylesheet' type='text/css'>
	
	<link rel="alternate" type="application/rss+xml" title="Yukon News - News" href="/rss/">
	<link rel="alternate" type="application/rss+xml" title="Yukon News - Letters & Opinions" href="/rss/letters_opinions/">
	<link rel="alternate" type="application/rss+xml" title="Yukon News - Multimedia" href="/rss/multimedia">
	
	<link rel="stylesheet" type="text/css" href="http://www.yukon-news.com/assets/cache/58c1b31c5af2558a2b6c592ac479c84b7a632f30.1395853663.v1.57.css">	
	
	
		<script type="text/javascript">
			var ads_spec = {
				network_code: "17528958",
				slots: {"leader":{"name":"Opinions_ATF_Top_970x90","width":"970","height":"90","platform":"web","description":"Top banner on Opinions section","id":"google_ad_1"},"sidebar":{"name":"Opinions_ATF_Right_300x250","width":"300","height":"250","platform":"web","description":"Sidebar rectangle on Opinions section","id":"google_ad_2"},"content":{"name":"Opinions_BTF_Content_300x250","width":"300","height":"250","platform":"web","description":"Content rectangle on Opinions section","id":"google_ad_4"},"mobile":{"name":"Opinions_Mobile_320x50","width":"320","height":"50","platform":"web","description":"Bottom mobile banner on Opinions section","id":"google_ad_5"},"wallpaper":{"name":"Opinions_ATF_Wall_1x1","width":"1","height":"1","platform":"web","description":"Wallpaper takeover on Opinions section","id":"google_ad_0"},"sidebar2":{"name":"Opinions_BTF_Right_300x250","width":"300","height":"250","platform":"web","description":"Lower sidebar rectangle on Opinions section","id":"google_ad_3"}}			};
		</script>

	
	<script type="text/javascript" src="http://www.yukon-news.com/assets/cache/43b647a4201f077bf53d380ecf387a77e2629561.1445384471.v1.57.js"></script>
		
	<script type="text/javascript">


		var _gaq = _gaq || [];
			_gaq.push(["_setAccount", "UA-6969668-1"]);
			_gaq.push(["_trackPageview"]);




		
		$.loadScript( "https:" == document.location.protocol ? "https://ssl.google-analytics.com/ga.js" : "http://www.google-analytics.com/ga.js" );

	

	</script>
</head>

<body>

	<div class="adslot wallpaper">
					<div id="google_ad_0"></div>

	</div>

	
	<div id="viewport">
	
		<div id="page">
		
			<header id="masthead">
				<div id="leaderboard" class="adslot leaderboard">
								<div id="google_ad_1"></div>

				</div>
			
				<h1>
					<a href="/" title="Yukon News">Yukon News</a>
				</h1>
								
				<nav id="navigation" class="menu">
						<h2 class="outline">Navigation</h2>
						<ul><li class=""><a href="/">Home</a></li><li class=""><a href="/news/">News</a></li><li class=""><a href="/sports/">Sports</a></li><li class=""><a href="/business/">Business</a></li><li class=""><a href="/arts/">Arts</a></li><li class=""><a href="/life/">Life</a></li><li class=" active"><a href="/letters-opinions/">Letters & Opinions</a></li><li class=""><a href="/multimedia/">Multimedia</a></li><li class=""><a href="/information/e-edition/">E-Edition</a></li><li class=""><a href="/games/">Games</a></li>	</ul>
					  </nav>		
				
			</header>


			<div id="main">
				
								
				<nav id="search">					
					<form method="post" action="http://www.yukon-news.com/"  >
<div class='hiddenFields'>
<input type="hidden" name="XID" value="e81b6007c52faa1d7c23dafcefb651ca03b9620c" />
<input type="hidden" name="params" value="eyJyZXN1bHRfcGFnZSI6ImFyY2hpdmVzXC9zZWFyY2gifQ" />
<input type="hidden" name="ACT" value="44" />
<input type="hidden" name="site_id" value="1" />
</div>


					<h2 class="outline">Search</h2>
					<fieldset>
						<input type="hidden" name="advanced" />
						<input type="text" name="keywords" class="keywords" placeholder="Search" />
						<input type="submit" name="submit" class="submit" value="Search Archives">
					</fieldset>
					</form>
				</nav>
				
								
				
				<aside id="sidebar">
					<h2 class="outline">Sidebar</h2>
					
					<article class="block like-api first sidebar-only">
						<div class="twitter-follow"><a href="https://twitter.com/yukon_news" class="twitter-follow-button" data-show-count="false" data-lang="en">Follow @yukon_news</a></div>
						<div class="fb-like" data-href="http://www.facebook.com/pages/Yukon-News/186396428426" data-send="false" data-layout="button_count" data-width="450" data-show-faces="false" data-font="lucida grande"></div>
					</article>
					
					<article class="block popular first sidebar-only">
						<h3>Popular Stories</h3>
						
						<div class="indent">
						
						
							<article class="teaser title">
								<a href="/news/kaska-seek-15b-settlement-23-per-cent-of-yukon-in-land-claim/" title="Kaska seek $1.5B settlement, 23 per cent of Yukon in land claim">
									<h4>Kaska seek $1.5B settlement, 23 per cent of Yukon in land claim <span class="comments">18</span></h4>
								</a>
							</article>
							<article class="teaser title">
								<a href="/news/taxpayers-on-hook-for-1.8-million-to-shut-down-kotaneelee-well/" title="Taxpayers on hook for $1.8 million to shut down Kotaneelee well">
									<h4>Taxpayers on hook for $1.8 million to shut down Kotaneelee well <span class="comments">16</span></h4>
								</a>
							</article>
							<article class="teaser title">
								<a href="/news/infill-proposal-deceiving-says-whitehorse-copper-resident/" title="Infill proposal ‘deceiving’ says Whitehorse Copper resident">
									<h4>Infill proposal ‘deceiving’ says Whitehorse Copper resident <span class="comments">13</span></h4>
								</a>
							</article>
							<article class="teaser title">
								<a href="/news/whitehorse-council-bans-motorized-vehicles-on-whistle-bend-trail/" title="Whitehorse council bans motorized vehicles on Whistle Bend trail">
									<h4>Whitehorse council bans motorized vehicles on Whistle Bend trail <span class="comments">12</span></h4>
								</a>
							</article>
							<article class="teaser title">
								<a href="/news/local-business-shuts-down-off-sales-amid-public-concern/" title="Local business shuts down off-sales amid public concern">
									<h4>Local business shuts down off-sales amid public concern <span class="comments">11</span></h4>
								</a>
							</article>						</div>
					</article>
					
					<article class="block classified-link sidebar-only">
						<h3><a href="/classifieds/" title="Submit a Classified">Submit a Classified</a></h3>
					</article>
					
					
					<div class="block adslot rectangle">
									<div id="google_ad_2"></div>

					</div>
					
					<article class="block ca150 sidebar-only">
						<a href="http://blackpressdeals.secondstreetapp.com/20000-Canadian-Prize-Giveaway/" target="_blank" title="Click here to enter!"><img src="/assets/layout/Canada150ad.gif" alt="Canadian Prize Giveaway"></a>
					</article>
										
					<article class="block wyatt sidebar-only">
						<h3><a href="/multimedia/wyatts-world/" title="Wyatt's World">Wyatt's World</a></h3>
						 
							<a href="/multimedia/wyatts-world/2017/06/30147/" title="Wyatt's World - Jun 20, 2017"><img id="cartoon_img" src="http://www.yukon-news.com/media/images/2017/june/20/_medium/cartoon.jpg" alt="Wyatt's World - Jun 20, 2017"></a>
						
					</article>									

					<div class="block adslot rectangle">
									<div id="google_ad_3"></div>

					</div>
					
														
					
					
					
					<article class="block multimedia sidebar-only">
						<h3><a href="/multimedia/">Multimedia</a></h3>
							
						<div class="col half col1">
							
							<article class="teaser video">
								<a href="/multimedia/yukon-kennel-club-dog-show/" title="Yukon Kennel Club Dog Show">
																			<figure class="thumb"><img src="http://i.vimeocdn.com/video/639784849_200x150.jpg" alt="Yukon Kennel Club Dog Show"></figure>
																		<h4>Yukon Kennel Club Dog Show</h4>
								</a>
							</article>
							
						</div>
							
						<div class="col half col2">
							
							<article class="teaser video">
								<a href="/multimedia/canadian-arctic-aviation-tour/" title="Canadian Arctic Aviation Tour">
																			<figure class="thumb"><img src="http://i.vimeocdn.com/video/638564739_200x150.jpg" alt="Canadian Arctic Aviation Tour"></figure>
																		<h4>Canadian Arctic Aviation Tour</h4>
								</a>
							</article>
							
						</div>
												
					</article>				
					
					<article class="block games sidebar-only">
						<h3><a href="/games/" title="Games">Games</a></h3>						
						<script id='arkWidgetScript' async type='text/javascript' src='//widget.as.arkadiumhosted.com/js/widget.js'></script>
						<div class='arkwidget' id='yukonhearstwidget' data-ark-url='http://games.yukon-news.com/'></div>
					</article>				
					
					
					
				</aside><!-- end sidebar -->

						
				<section id="content">
					
											

	
	
				
	<article class="story">
		<h4>Problems with legal aid</h4>
		
						<p class="meta"> <span class="date">Friday June 9, 2017</span></p>
					
		<div class="story-fb-like">
		<iframe src="http://www.facebook.com/plugins/like.php?href=http%3A%2F%2Fwww.yukon-news.com%2Fletters-opinions%2Fproblems-with-legal-aid%2F&amp;layout=standard&amp;show_faces=false&amp;width=450&amp;action=recommend&amp;colorscheme=light&amp;height=80" scrolling="no" frameborder="0" style="border:none; overflow:hidden; width:450px; height:40px;" allowTransparency="true"></iframe>
</div>			


		
		<div class="body">
		<p>
 I have several children with different moms here in Whitehorse. I have been having difficulties with some of the mothers providing me with adequate visitation or none at all. I need a legal aid lawyer to help me with these custody and access agreements.</p>

<p> I was appointed a lawyer last July. It is now June 2017. I met with my lawyer once and we went over the files.</p>

<p> I have called frequently to check on the progress and I keep being told the lawyer is busy and hasn&rsquo;t had time to work on it. This is going on 10 months now.</p>

<p> I haven&rsquo;t been able to see some of my kids because of this and I fear my relationship with them is being lost. It also affects my living situation as I have applied for housing and been approved but I can&rsquo;t get a place until I have court-filed documents showing the 50/50 custody agreements. Two mothers have already written letters saying they&rsquo;re in agreement. These need to be re-written by lawyers but this hasn&rsquo;t happened yet.<div class="adslot rectangle">
								<div id="google_ad_4"></div>

				</div></p>

<p> The lawyers are good and I appreciate the service they provide. When I voiced my concerns they told me they are under-staffed overworked and there&rsquo;s not enough money in the budget. I urge the government to help.</p>

<p> <em>Lee Goodwin, </em></p>

<p> <em>Whitehorse</em></p>
		</div>
	
	</article>



																			
					
					<div class="comments">
	
	<div class="social">
		<span class='st_facebook' displayText='Facebook'></span>
		<span class='st_twitter' displayText='Tweet'></span>
		<span class='st_linkedin' displayText='LinkedIn'></span>
		<span class='st_pinterest' displayText='Pinterest'></span>
		<span class='st_delicious' displayText='Delicious'></span>
		<span class='st_email' displayText='Email'></span>
	</div>
	
	
	
	
	
			<h4><span>2 Comments</span></h4>
					
		
		<div class="comment first">
			<div class="comment-meta">			
				<div class="comment-name"><strong>ProScience Greenie</strong> wrote:</div>
				<div class="comment-date">4:33pm Thursday June 22, 2017</div>
			</div>
			<div class="comment-content">
				<p>&#8220;I have several children with different moms&#8230;&#8221;.&nbsp; Well there&#8217;s your problem right there guy. Maybe try wrapping up more often and try to think with the big head rather than the other one. Less collateral damage for all involved that way. Also less of a need for lawyers.</p>
			</div>
			<div style="clear:left;"></div>
		</div>
		
	
	
	
	
					
		
		<div class="comment">
			<div class="comment-meta">			
				<div class="comment-name"><strong>Alan</strong> wrote:</div>
				<div class="comment-date">3:06pm Wednesday June 21, 2017</div>
			</div>
			<div class="comment-content">
				<p>The government is not responsible for your poor planning or choices.<br />
Do you know who is?</p>
			</div>
			<div style="clear:left;"></div>
		</div>
		
	



	<h4><span>Add a comment</span></h4>
	<div class="form-comment">
		
	<form id="comment_form" method="post" action="http://www.yukon-news.com/letters-opinions/problems-with-legal-aid"  >
<div class='hiddenFields'>
<input type="hidden" name="ACT" value="1" />
<input type="hidden" name="RET" value="http://www.yukon-news.com/letters-opinions/problems-with-legal-aid" />
<input type="hidden" name="URI" value="letters-opinions/problems-with-legal-aid" />
<input type="hidden" name="PRV" value="" />
<input type="hidden" name="XID" value="d2308234cf878a58e9b50477d500871352e45f3d" />
<input type="hidden" name="entry_id" value="30088" />
<input type="hidden" name="site_id" value="1" />
</div>


		
		
				
		<p class="note">The Yukon News welcomes your comments and insight. We encourage a healthy environment for debate that is inclusive, thoughtful and respectful.<br /><br />
The comments are moderated. Personal attacks, vulgarity, profanity, unsubstantiated allegations, hateful comments and incoherence will not be tolerated.<br /><br />
If you have a complaint regarding a comment or have a question please contact the web administrator at <a href="mailto:webadmin@yukon-news.com">webadmin@yukon-news.com</a>.</p>

				<div class="line-reverse captcha">
			<label for="captcha">Please enter the word you see in the image:</label>
			<div><img src="http://www.yukon-news.com/images/captchas/1498229397.6017.jpg" width="140" height="30" style="border:0;" alt=" " /> <input type="text" name="captcha" value="" maxlength="20" style="width:135px;"></div>
		</div>
		
					<div class="line"><label for="name">Name:</label> <input type="text" name="name" value="" size="50"></div>
			<div class="line"><label for="email">Email: <em>(optional)</em></label> <input type="text" name="email" value="" size="50"></div>
			
		<div class="line message"><label for="comment">Comment:</label><textarea name="comment" cols="60" rows="10"></textarea></div>	
		<div class="line-submit right">
			<input type="submit" name="submit" class="submit" value="Post my comment">
		</div>
		<div class="line-reverse"><input type="checkbox" name="notify_me" value="yes" ><label>Notify me of follow-up comments?</label></div>			
		
	</form>
	</div>
	
</div>

					
					
				</section><!-- end content -->

				<div class="clearbox"></div>
			</div><!-- end main -->

			

			<nav id="footer" class="base" data-role="footer">
				<h2 class="outline">Footer</h2>
				
				<div class="col quarter first">
					<ul>
						<li><a href="/classifieds/" title="Classifieds">Classifieds</a></li>
						<li><a href="/information/display-advertising/" title="Display Ads">Display Ads</a></li>
						<li><a href="/information/e-edition/" title="E-Edition">E-Edition</a></li>
					</ul>
				</div>
				<div class="col quarter">
					<ul>
						<li><a href="/archives/search/" title="Search">Search</a></li>
						<li><a href="/information/archives-reprints/" title="Archives &amp; Reprints">Archives &amp; Reprints</a></li>
						<li><a href="/information/rights-permissions/" title="Rights &amp; Permissions">Rights &amp; Permissions</a></li>
					</ul>
				</div>
				<div class="col quarter">
					<ul>
						<li><a href="/information/about-us/" title="About Us">About Us</a></li>
						<li><a href="/information/contact-us/" title="Contact Us">Contact Us</a></li>
						<li><a href="/information/rss/" title="RSS Feeds">RSS Feeds</a></li>
					</ul>
				</div>
				<div class="col quarter">
					<ul>
						<li><a href="/information/privacy-policy/" title="Privacy Policy">Privacy Policy</a></li>
						<li><a href="/information/terms-of-use/" title="Terms of Use">Terms of Use</a></li>
					</ul>
				</div>
				
				<footer class="copyright">&copy; Copyright 2017 &nbsp; Yukon News &nbsp; All Rights Reserved</footer>
			</nav>
			
			
		</div><!-- end div#page -->
	</div><!-- end div#viewport -->

	<div class="adslot mobile">
					<div id="google_ad_5"></div>

	</div>

</body>
</html>
